NeoEdge.exe strange rectangles - Forum

Forum Navigation
You need to log in to create posts and topics.

NeoEdge.exe strange rectangles

When I open a website with NeoEdge.exe embedded in my app, I always see five strange rectangles at the top left of my window. It happens both with VisualNEO Win and Neobook 5.

How can I correct this?

Thanks

Uploaded files:
  • You need to login to have access to uploads.

Hi @fkapnist,

No. That's strange. How can I reproduce the problem?

Regards.

fkapnist has reacted to this post.
fkapnist

I just did a test with a second computer and the rectangles did not appear there. So there seems to be a display incompatibility with my HP Compaq desktop PC. I am not sure yet if it's hardware-related (Nvidia graphics card) or a faulty Windows 10 update (WebView2Loader dll) ?.... I hoped NeoEdge.exe would be an essential tool, but I am still not quite sure how it will display on other user's machines. So for now, it seems less risky to just embed the Chrome or Edge browser in a rectangle and leave it at that. Thanks for your concern. Also check out where else NeoEdge may not be 100% compatible.

@fkapnist I added some rectangles on the left side to be used from VisualNEO Win code just in case (Rectangle1, Rectangle2, Rectangle3...)
I think you are watching them, but they should be hidden unless you programatically use them and change their position.

You can take a look at the neoEdge source code for VisualNEO Win here:
https://visualneo.com/forum/topic/neoedge-source-code

Regards.

Quote from luishp on July 12, 2022, 9:13 pm

@fkapnist I added some rectangles on the left side to be used from VisualNEO Win code just in case (Rectangle1, Rectangle2, Rectangle3...)
I think you are watching them, but they should be hidden unless you programatically use them and change their position.

You can take a look at the neoEdge source code for VisualNEO Win here:
https://visualneo.com/forum/topic/neoedge-source-code

Regards.

I added some rectangles on the left side to be used from VisualNEO Win code just in case

Yes, the rectangles are from the NeoEdge.pub  and they are 30 pixels into the client area. But why are they visible at all? They should be hidden. When I compile from my HP desktop the rectangles will appear, but not when I compile from another PC. I wonder what the cause of this is? I did not change anything programatically and I used the latest download of NeoEdge....  I will keep looking

Can the "package . json" file be edited to hide the rectangles or change the left margin?

Hi @fkapnist, I have uploaded a new neoEdge version that should fix the problem.
Please download it from the downloads section and let me know if it is fixed.
Thank you!
Regards.

I downloaded the new neoEdge version. But the rectangles are still there. However, you did remove their thick black line borders...  So we made some progress,  but we're still not there. I wonder why those rectangles appear when I compile from my Intel Core i5  processor, but not when I compile from a Celeron? Very strange indeed. I will keep trying...

Uploaded files:
  • You need to login to have access to uploads.
Quote from luishp on July 13, 2022, 7:17 am

Hi @fkapnist, I have uploaded a new neoEdge version that should fix the problem.
Please download it from the downloads section and let me know if it is fixed.
Thank you!
Regards.

If the rectangles are there just in case, can't you make a version of neoEdge without them?

After downloading the new neoEdge version I noticed that the strange rectangles will now appear in the app display regardless of which PC I compile from!

Oh no!

Please NOTE: The WebView2 Runtime  for Edge comes in three flavors, depending on your CPU:

x86
x64
ARM64

I think the choice of installation may determine just how the VisualNEO app will finally compile. Many users don't know what CPU they have, so this Microsoft download is somewhat unclear...

 

Uploaded files:
  • You need to login to have access to uploads.

As a test, I compiled the "content-slider-demo" sample with NeoEdge.exe on a Windows 10 tablet using an ATOM processor. The published exe file worked just fine. But when I copied the published exe to a HP desktop PC with a Core i5 processor, the content-slider app worked, but the strange rectangles also re-appeared. When I copied the published exe to a mini PC with Celeron processor, only the strange rectangles appeared, and the rest of the window was totally blank!  So there is no way of knowing what another person's system will actually display? I don't get it... Maybe removing the rectangles from the NeoEdge source code is the best solution.....

@fkapnist I think you are right. I have deleted the rectangles and updated the neoEdge.exe file.
Please confirm everything works fine now.

Thank you!

Quote from luishp on July 14, 2022, 8:04 pm

@fkapnist I think you are right. I have deleted the rectangles and updated the neoEdge.exe file.
Please confirm everything works fine now.

Thank you!

The new version of NeoEdge.exe works fine, without any rectangles. I had to re-install the WebView2Loader on one machine, but other than that, everything is okay! Thanks!

luishp and Darbdenral have reacted to this post.
luishpDarbdenral
Open chat
1
Do you need more info?
Hi, do you have any doubt?