Neotopmenu - Forum

Forum Navigation
You need to log in to create posts and topics.

Neotopmenu

@luishp Perdona que te vuelva a molestar, estoy usando neotopmenu, y depende del ancho de la aplicación el icono se posiciona a la derecha o a la izquierda del titulo. ¿De que manera puedo bloquear este comportamiento, para que el icono siempre esté a la izquierda de titulo? Muchas gracias.

@ivanes82 si tienes razón, es un poco raro (lo arreglaré en la próxima versión) De momento añade este estilo CSS y listo:

.navbar-left{
   float:left;
}

Saludos!

Ivanes82 has reacted to this post.
Ivanes82

Genial @luishp, Muchas gracias.

Hi..

Also facing some visual issues with NeoTopMenu.

In all modes (Default - StaticTop - fixedTop) in certain dimensions the menu presents 2 or 3 lines instead of 1. Is it possible to fix that ? Is very annoying specially when you see it from mobile phone, it covers the half of the screen when the mode is FixedTop.

In fixedTop possition the dropdown menu with 4 button is not showing all the button when the menu is in hamburger mode, instead it shows scrollbar.

 

 

 

 

Uploaded files:
  • You need to login to have access to uploads.

@smartmedia neoTopMenu plugin uses BootStrap 3 NavBar. Any custom CSS for that component should work with neoTopMenu.
Anyway please attach a sample app so I can better understand what you are talking about.
Thank you!

Hi @luishp

Check the app please. Thanks.

 

Uploaded files:
  • You need to login to have access to uploads.

@smartmedia, to show all the options in the right menu (hamburguer mode) delete the separator (it seems it is the one causing the problem).

To avoid the scrollbar, add this code to Project > Properties > Styles

.navbar-collapse{
   overflow:visible!important;
}

To avoid two lines when the horizontal space is not enough you must delete any main menu option and group them in submenus. That's the way it works. Sorry.

 

Hi @luishp

I have test all the possible combinations, remove the separator is not affect at all the scroll bars, they show up again. The important; either does not seem to work.

I have choose to keep the option to Default since is the only option that shows the all menu without scrollbars in hamburger mode. I will search for a solution on web and if i find i will inform the topic. Thanks for your time.

@smartmedia it works for me. Please check the attached app.

Uploaded files:
  • You need to login to have access to uploads.
Open chat
1
Do you need more info?
Hi, do you have any doubt?